↑↓ 选择↵ 打开⌫ 切换范围完整搜索

PG.CENTER 连接 PostgreSQL 文档、百科与生态知识。由 Pigsty 维护。

CREATE SUBSCRIPTION 的 pg_dump 恢复失败已修 RSS

Jeff Davis 提交补丁,修复 commit 8185bb5 之后 CREATE SUBSCRIPTION ... SERVER 在 pg_dump 加 restore 时的两处失败:DDL 阶段对订阅属主、foreign server 的 ACL 和 user mapping 检查过严,而 pg_dump 先建订阅再改属主,第一步就会失败。这些条件在真正连接前还会变化,补丁因此放宽检查,并补了 SQL 测试。

发布于 2026-09-10T10:59:46.404338Z · Jeff Davis · PostgreSQL hackers
pg_dump 补丁 逻辑复制

Jeff Davis 提交补丁,修复 commit 8185bb5 之后 CREATE SUBSCRIPTION ... SERVER 在 pg_dump 加 restore 时的两处失败:DDL 阶段对订阅属主、foreign server 的 ACL 和 user mapping 检查过严,而 pg_dump 先建订阅再改属主,第一步就会失败。这些条件在真正连接前还会变化,补丁因此放宽检查,并补了 SQL 测试。

Jeff Davis 提交补丁,修复 commit 8185bb5 之后 CREATE SUBSCRIPTION ... SERVER 在 pg_dump 加 restore 时的两处失败:DDL 阶段对订阅属主、foreign server 的 ACL 和 user mapping 检查过严,而 pg_dump 先建订阅再改属主,第一步就会失败。这些条件在真正连接前还会变化,补丁因此放宽检查,并补了 SQL 测试。

原始来源 ↗

来源记录
  • center.info_item · 24b9c6f7bc1d0143 · 2026-10-03T04:08:35.169032Z
  • pgweb.info_item · 24b9c6f7bc1d0143 · 2026-10-03T04:08:55.967155Z