发布于 2026-09-10T10:59:45.96781Z · Santosh Mishra · AWS 数据库博客

在 Aurora PostgreSQL 上重建大索引时,REINDEX 会把排序中间数据溢写到磁盘,临时空间不够就会失败。文章的做法是把重建放进蓝绿部署的 green 环境,配合 Aurora Optimized Reads,用带 NVMe 的实例让排序数据落到本地盘而不是走网络访问 EBS。实测一个膨胀到 8918 MB 的索引约四分钟重建到 4557 MB,期间写了约 19.5 GB 临时数据。
在 Aurora PostgreSQL 上重建大索引时,REINDEX 会把排序中间数据溢写到磁盘,临时空间不够就会失败。文章的做法是把重建放进蓝绿部署的 green 环境,配合 Aurora Optimized Reads,用带 NVMe 的实例让排序数据落到本地盘而不是走网络访问 EBS。实测一个膨胀到 8918 MB 的索引约四分钟重建到 4557 MB,期间写了约 19.5 GB 临时数据。
来源记录
- center.info_item · 85290f06132cf3b3 · 2026-10-03T04:08:35.169032Z
- pgweb.info_item · 85290f06132cf3b3 · 2026-10-03T04:08:55.967155Z